Configurar una VLAN y enlaces troncales en un Switch Cisco

A continuación veremos como crear dos redes LAN virtuales (VLAN) usando un Switch Cisco. Lo que queremos lograr

Ejercicio propuesto

A las Laptops la confuguraremos con los siguientes parámetros:

  • Laptop0: ip = 192.168.1.2/24 default gateway = 192.168.1.1
  • Laptop1: ip = 192.168.1.3/24 default gateway = 192.168.1.1
  • Laptop2: ip = 172.16.1.2/24 default gateway = 172.16.1.1
  • Laptop3: ip = 172.16.1.3/24 default gateway = 172.16.1.1

A continuación los comandos mínimos de configuración necesarios del Router, nótese que la misma interfaz (fastEthernet 0/0), debe tener 2 IPs, ya que, el Router será el Default Gateway de las dos redes virtuales. Esto se logra con un enlace trocal, el protocolo más común para esto se llama 802.1Q. Los comandos para lograr esto son:

enable
configure terminal
interface fastEthernet 0/0
no shutdown
exit

 

interface fastEthernet 0/0.10
encapsulation dot1Q 10
ip address 192.168.1.1 255.255.255.0
exit


interface fastEthernet 0/0.20

encapsulation dot1Q 20
ip address 172.16.1.1 255.255.255.0

Note que 0/0.20 es una manera de decir que estamos creando una subinterfaz 20 dentro de la interfaz 0/0 del router y que usaremos encapsulación dot1Q.

Ahora los comandos del Switch, primero configuramos la VLAN 10, que se llamará GERENCIA.

enable
vlan database
vlan 10 name GERENCIA
exit


configure terminal

interface fastEthernet 0/1
switchport mode access
switchport access vlan 10
exit

 

interface fastEthernet 0/2
switchport mode access
switchport access vlan 10
exit

No se recomienda el uso de el comando vlan database, ya que, los cambios se guardan al salir del modo de configuración, si tenemos muchas interfaces configuradas, todas serán guardadas al final, note también que se configuró cada una de las interfaces por separado, se pueden configurar varias interfaces a la vez con rangos.

A continuación veremos los comandos para configurar la VLAN 20 haciando uso de las mejores prácticas:

enable
configure terminal
vlan 20
name RRHH
exit


interface range fastEthernet 0/3 – 4

switchport mode access
switchport access vlan 20

Note que no se usa el comando vlan database, además el uso de la opción range… Ahora sólo falta establecer la conexión troncal para que el Switch permita el trafico de las dos redes virtuales hacia el Router.

enable
configure terminal
interface fastEthernet 0/24
switchport mode trunk

A continuación otros comandos que nos pueden ser de utilidad mientras estamos creando VLAN.

Ver las VLAN creadas:
show vlan

configurar varias interfaces no consecutivas:
interface range fastEthernet 0/5 , fastEthernet 0/9

ver tablas de MacAddress en Switch con plataforma nueva:
show mac address-table

ver tablas de MacAddress en Switch con plataforma antigua:
show mac-address-table

Ver información de enlaces troncales:
ip interfaces trunk

Configuración de un dispositivo CISCO (Visión general)

Al igual que una computadora personal, un router o switch no puede funcionar sin un sistema operativo. Sin un sistema operativo, el hardware no puede realizar ninguna función. El sistema operativo Internetwork (IOS) de Cisco es el software del sistema en dispositivos Cisco. Es la tecnología principal de Cisco y está presente en casi todos sus productos. El Cisco IOS se utiliza en la mayoría de los dispositivos Cisco, independientemente del tamaño o tipo de dispositivo. Se usa en routers, switches LAN, pequeños puntos de acceso inalámbricos, grandes routers con decenas de interfaces y muchos otros dispositivos.

El Cisco IOS provee a los dispositivos los siguientes servicios de red:

  • Funciones básicas de enrutamiento y conmutación.
  • Acceso seguro a recursos en red.
  • Escalabilidad de la red.

Los detalles operativos de IOS varían de acuerdo con los diferentes dispositivos de internetworking, según el propósito y el conjunto de características del dispositivo.

Por lo general, se tiene acceso a los servicios que proporciona el IOS de Cisco mediante una Interfaz de línea de comandos (CLI). Las funciones accesibles a través de la CLI varían según la versión de IOS y el tipo de dispositivo.

Métodos de acceso

Existen varias formas de acceder al entorno de la CLI. Los métodos más comunes son:

  • Consola
  • Telnet o SSH
  • Puerto auxiliar

 Interfaces-Router-CISCO

Los dispositivos de red dependen de dos tipos de software para su funcionamiento: el sistema operativo y la configuración. Al igual que el sistema operativo en cualquier equipo, el sistema operativo facilita la operación básica de los componentes de hardware del dispositivo.

Los archivos de configuración contienen los comandos del software IOS de Cisco utilizados para personalizar la funcionalidad de un dispositivo Cisco. Los comandos son analizados (traducidos y ejecutados) por el software IOS de Cisco cuando inicia el sistema (desde el archivo startup-config) o cuando se ingresan los comandos en la CLI mientras está en modo configuración.

El administrador de red crea una configuración que define la funcionalidad deseada del dispositivo Cisco.

Un dispositivo de red Cisco contiene dos archivos de configuración:

  • El archivo de configuración en ejecución, utilizado durante la operación actual del dispositivo.
  • El archivo de configuración de inicio, utilizado como la configuración de respaldo, se carga al iniciar el dispositivo.

También puede almacenarse un archivo de configuración en forma remota en un servidor a modo de respaldo.

El Cisco IOS está diseñado como un sistema operativo modal. El término modal describe un sistema en el que hay distintos modos de operación, cada uno con su propio dominio de operación. La CLI utiliza una estructura jerárquica para los modos.

En orden descendente, los principales modos son:

  • Modo de ejecución usuario
  • Modo de ejecución privilegiado
  • Modo de configuración global
  • Otros modos de configuración específicos

Cada modo se utiliza para cumplir determinadas tareas y tiene un conjunto específico de comandos que se encuentran disponibles cuando el modo está habilitado. Por ejemplo, para configurar una interfaz del router, el usuario debe ingresar al modo de configuración de interfaces. Todas las configuraciones que se ingresan en el modo de configuración de interfaz se aplican sólo a esa interfaz.

Cuando se usa la CLI, el modo se identifica mediante la petición de entrada de línea de comandos que es exclusiva de ese modo (también llamado prompt).

prompt-indicador-router-cisco-ios

En un artículo posterior veremos un listado de los comandos básicos para configurar un dispositivo Cisco.

Capa Física OSI

La capa física de OSI proporciona los medios de transporte para los bits que conforman la trama de la capa de Enlace de datos a través de los medios de red. Esta capa acepta una trama completa desde la capa de Enlace de datos y lo codifica como una secuencia de señales que se transmiten en los medios locales. Un dispositivo final o un dispositivo intermedio recibe los bits codificados que componen una trama.

El envío de tramas a través de medios de transmisión requiere los siguientes elementos de la capa física:

  • Medios físicos y conectores asociados.
  • Una representación de los bits en los medios.
  • Codificación de los datos y de la información de control.
  • Sistema de circuitos del receptor y transmisor en los dispositivos de red.

El objetivo de la capa física es crear la señal óptica, eléctrica o de microondas que representa a los bits en cada trama. Luego, estas señales se envían por los medios una a la vez.

Otra función de la capa física es la de recuperar estas señales individuales desde los medios, restaurarlas para sus representaciones de bit y enviar los bits hacia la capa de Enlace de datos como una trama completa.

Existen tres tipos básicos de medios de red en los cuales se representan los datos (La presentación de los bits depende del tipo de medio):

  • Cable de cobre
  • Fibra
  • Inalámbrico

Cuando la capa física codifica los bits en señales para un medio específico, también debe distinguir dónde termina una trama y dónde se inicia la próxima. De lo contrario, los dispositivos de los medios no reconocerían cuándo se ha recibido exitosamente una trama. En tal caso, el dispositivo de destino sólo recibiría una secuencia de señales y no sería capaz de reconstruir la trama correctamente. Como se describió en el capítulo anterior, indicar el comienzo de la trama es a menudo una función de la capa de Enlace de datos. Sin embargo, en muchas tecnologías, la capa física puede agregar sus propias señales para indicar el comienzo y el final de la trama.

las tecnologías de la capa física se definen por diferentes organizaciones, tales como:

  • La Organización Internacional para la Estandarización (ISO)
  • El Instituto de Ingenieros Eléctricos y Electrónicos (IEEE)
  • El Instituto Nacional Estadounidense de Estándares (ANSI)
  • La Unión Internacional de Telecomunicaciones (ITU)
  • La Asociación de Industrias Electrónicas/Asociación de la Industria de las Telecomunicaciones (EIA/TIA)
  • Autoridades de las telecomunicaciones nacionales, como la Comisión Federal de Comunicaciones (FCC) en EE.UU.

Las tecnologías definidas por estas organizaciones incluyen cuatro áreas de estándares de la capa física:

  • Propiedades físicas y eléctricas de los medios
  • Propiedades mecánicas (materiales, dimensiones, diagrama de pines) de los conectores
  • Representación de los bits por medio de las señales (codificación)
  • Definición de las señales de la información de control

Las tres funciones esenciales de la capa física son:

  • Los componentes físicos: son los dispositivos electrónicos de hardware, medios y conectores que transmiten y transportan las señales para representar los bits.
  • Codificación de datos: método utilizado para convertir un stream de bits de datos en un código predefinido. Los códigos son grupos de bits utilizados para ofrecer un patrón predecible que pueda reconocer tanto el emisor como el receptor.
  • Señalización: método de representación de bits.

Los bits se representan en el medio al cambiar una o más de las siguientes características de una señal:

  • Amplitud
  • Frecuencia
  • Fase

amplitud-frecuencia-fase

Señalización NRZ

En NRZ, el stream de bits se transmite como una secuencia de valores de voltaje.

Un valor de bajo voltaje representa un 0 lógico y un valor de alto voltaje representa un 1 lógico. El intervalo de voltaje depende del estándar específico de capa física utilizado.

Este método simple de señalización sólo es adecuado para enlaces de datos de velocidad lenta. La señalización NRZ no utiliza el ancho de banda de manera eficiente y es susceptible a la interferencia electromagnética. Además, los límites entre bits individuales pueden perderse al transmitir en forma consecutiva secuencias largas de 1 ó 0. En dicho caso, no se detectan transiciones de voltaje en los medios. Por lo tanto, los nodos receptores no tienen una transición para utilizar al resincronizar tiempos de bit con el nodo transmisor.

Codificación Manchester

En el esquema de codificación Manchester, los valores de bit se representan como transiciones de voltaje, una transición desde un voltaje bajo a un voltaje alto representa un valor de bit de 1. Una transición desde un voltaje alto a un voltaje bajo representa un valor de bit de 0.

manchester

Un grupo de códigos es una secuencia consecutiva de bits de código que se interpretan y asignan como patrones de bits de datos. Por ejemplo, los bits de código 10101 pueden representar los bits de datos 0011.

Entre las ventajas de utilizar grupos de códigos se incluyen:

  • Reducción del nivel de error en los bits
  • Limitación de la energía efectiva transmitida a los medios
  • Ayuda para distinguir los bits de datos de los bits de control
  • Mejoras en la detección de errores en los medios

Fuente: Exploration: Aspectos básicos de networking (CISCO).