Configurar Fiddle para Nox

Fiddle es una herramienta que nos podría servir para pruebas y depuración de aplicaciones Android, particularmente usando el emulador Nox. Es importante destacar que es posible que algunas páginas en Internet y aplicaciones no funcionen mientras tengas el Fiddle activado.

Configurando Fiddler

  1. Luego de instalarlo normalmente vamos a Tools > HTTP.
  2. Asegura que Capture HTTPs CONNECTs y Decrypt HTTPS traffic está chequeado y que “…from all process” está seleccionado.
  3. Click en Connections.
  4. Asegura que tienes seleccionado Allow remote computers to connect.
  5. Click en OK, reiniciar Fiddler.
  6. Arriba a la derecha hay un indicador que muestra “Online”, al pasar el ratón por encima se muestran las conexiones IPv4 o IPv6 y la dirección que está usando Fiddle.

Configurar Nox

  1. Selecciona el ícono de Ajustes (Settings).
  2. Selecciona WiFi.
  3. Selecciona y manten presionado sobre tu red actual hasta que aparezca la opción modificar la red.
  4. Selecciona Ver opciones avanzadas (Show advanced options).
  5. Selecciona Proxy settings y elige Manual.
  6. Escribe tu dirección IP y puerto (por defecto puerto 8888) del servidor Fiddler.
  7. Guarda los cambios.
  8. Para verificar la configuración navega la página http://ipv4.fiddler:8888/. La página mostrará la página de Fiddler Echo Service.
  9. En la página Fiddler Echo Service Webpage, selecciona FiddlerRoot Certificate.
  10. Dale nombre al certificado.
  11. Deberás colocar un PIN de bloqueo o contraseña.

Con esos pasos ya debería mostrarse el tráfico de Nox en Fiddler. Para filtrar el tráfico selecciona Show only traffic from y selecciona el nombre del proceso de Nox (NoxVMHandler.exe).

En caso de no poder instalar el certificado

  1. Ingresar en la opción de Settings de Nox (Ajustes).
  2. Seleccionar Personal > Security (Seguridad).
  3. En la sección Credential Storage (Almacenamiento de credenciales) Seleccionar Install from storage (Instalar desde la tarjeta SD o Almacenamiento).
  4. Seleccionar el archivo FiddlerRoot.cer.
  5. Ingresar un nombre para el certificado..
  6. Para verificar seleccione Trusted credentials (Certificados de confianza) > User (usuario). Se debería mostrar el certificado de Fiddler.

Revirtiendo los cambios

Después de usar Fiddler, solo se debe ir a la selección de proxy (en los Settings) y quitarlo.

Para borrar el certificado FiddlerRoot se selecciona Trusted credentials > User y luego visualizando el certificado Delete.

Fuente: http://www.iandrohacker.net/2017/02/configure-fiddler-for-android-emulator.html

Dos maneras de monetizar tu blog (con Publicidad)

Aunque los blog están un poco en decadencia, desplazados por Instagram o Facebook, siempre es posible monetizarlos y ganar algo de dinerillo con ellos, en especial si tienes una buena cantidad de visitas, a continuación dejo dos modos muy sencillos de monetizarlos.

1.- Google AdSense. es una herramienta bastante sencilla de usar de Google para recibir dinero por publicidad en tu blog, es de uso gratuito y si quieres integrarlo con WordPress, puedes descargar un plugin que se llama: “AdSense Integration WP QUADS”.

2.- Insertando publicidad de alguna empresa que te quiera pagar por poner una publicidad y otras herramientas de publicidad.

Otro consejo interesante es el intercambio de enlaces, un blog coloca un enlace a tu blog y tu colocas un enlace al blog o página de otra persona. Y otra cosa por la que te podrían pagar (pero eso es cuando tengas muchas más visitas), es publicar un artículo de una empresa, producto o servicio. (si por eso te pueden pagar xD).

Si tienes alguna duda de este o algún otro artículo puedes dejarla en la caja de comentarios debajo de cada artículo y te la contestaré a la brevedad posible (probablemente muchos otros lectores tengan la misma duda).

La fallida migración de Byethost a 000webhost ¿DNS?

Hace relativamente poco, tenía mi WordPress muy embasurado y obsoleto, pero un intento de actualización del blog conllevó a un error que no pude recobrar, probablemente un error en la comunicación que hizo que quedaran archivos corruptos.

Aproveché el problema para migrar el blog completo de Byethost a un renovado 000webhost que hasta ahora no me había dejado mal, tras largas horas y los cambios de los DNS logré cambiar el servidor y hacer que el blog se pareciera mucho a lo que tenía antes… Pero en 000webhost pasa horas abajo diariamente, eso ha generado que las visitas también vayan a menos.

Ahora, no estoy seguro si realmente es 000webhost, que está teniendo un rendimiento deplorable o es que los DNS no se han terminado de actualizar, o es mi blog que sigue embasurado (asunto menos probable, ya que, los períodos de inactividad son aparentemente aleatorios), lo importante es que en los próximos días, tendré que migrar de nuevo el blog, tengo la esperanza de hacerlo a un server propio, pero si no, tendré que volver a Byethost, lo importante es que mientras tanto, seguirán notando que el blog no carga en ciertos momentos, me disculpo por eso.

Recuerda que si te suscribes por correo, las cosas que voy publicando llegan directamente a tu correo (sin necesidad si quiera de ingresar directamente en la página).

Configurar una VLAN y enlaces troncales en un Switch Cisco

A continuación veremos como crear dos redes LAN virtuales (VLAN) usando un Switch Cisco. Lo que queremos lograr

Ejercicio propuesto

A las Laptops la confuguraremos con los siguientes parámetros:

  • Laptop0: ip = 192.168.1.2/24 default gateway = 192.168.1.1
  • Laptop1: ip = 192.168.1.3/24 default gateway = 192.168.1.1
  • Laptop2: ip = 172.16.1.2/24 default gateway = 172.16.1.1
  • Laptop3: ip = 172.16.1.3/24 default gateway = 172.16.1.1

A continuación los comandos mínimos de configuración necesarios del Router, nótese que la misma interfaz (fastEthernet 0/0), debe tener 2 IPs, ya que, el Router será el Default Gateway de las dos redes virtuales. Esto se logra con un enlace trocal, el protocolo más común para esto se llama 802.1Q. Los comandos para lograr esto son:

enable
configure terminal
interface fastEthernet 0/0
no shutdown
exit

 

interface fastEthernet 0/0.10
encapsulation dot1Q 10
ip address 192.168.1.1 255.255.255.0
exit


interface fastEthernet 0/0.20

encapsulation dot1Q 20
ip address 172.16.1.1 255.255.255.0

Note que 0/0.20 es una manera de decir que estamos creando una subinterfaz 20 dentro de la interfaz 0/0 del router y que usaremos encapsulación dot1Q.

Ahora los comandos del Switch, primero configuramos la VLAN 10, que se llamará GERENCIA.

enable
vlan database
vlan 10 name GERENCIA
exit


configure terminal

interface fastEthernet 0/1
switchport mode access
switchport access vlan 10
exit

 

interface fastEthernet 0/2
switchport mode access
switchport access vlan 10
exit

No se recomienda el uso de el comando vlan database, ya que, los cambios se guardan al salir del modo de configuración, si tenemos muchas interfaces configuradas, todas serán guardadas al final, note también que se configuró cada una de las interfaces por separado, se pueden configurar varias interfaces a la vez con rangos.

A continuación veremos los comandos para configurar la VLAN 20 haciando uso de las mejores prácticas:

enable
configure terminal
vlan 20
name RRHH
exit


interface range fastEthernet 0/3 – 4

switchport mode access
switchport access vlan 20

Note que no se usa el comando vlan database, además el uso de la opción range… Ahora sólo falta establecer la conexión troncal para que el Switch permita el trafico de las dos redes virtuales hacia el Router.

enable
configure terminal
interface fastEthernet 0/24
switchport mode trunk

A continuación otros comandos que nos pueden ser de utilidad mientras estamos creando VLAN.

Ver las VLAN creadas:
show vlan

configurar varias interfaces no consecutivas:
interface range fastEthernet 0/5 , fastEthernet 0/9

ver tablas de MacAddress en Switch con plataforma nueva:
show mac address-table

ver tablas de MacAddress en Switch con plataforma antigua:
show mac-address-table

Ver información de enlaces troncales:
ip interfaces trunk

Error 500 instalando un tema en WordPress

error500Aunque no es frecuente que esto ocurra, es posible que al instalar un tema (theme), en WordPress se produzca un error 500 que nos hará imposible el acceso ni al contenido, ni a la administración…

La manera más rápida de solucionar este inconveniente es renombrar la carpeta del tema vía FTP, esto forzará a que se visualice el tema por defecto (predeterminado), de la instalación.

Nota: si borraste el theme principal, la página pública se mostrará en blanco, pero podrás acceder a la administración.

Guia ó instructivo de uso del disco extraible (pendrive) (Por Ramón Certad)

El presente material es una idea de Ramón Certad, conocido en Twitter como @torteros la cual pretende ser una guía para usar correctamente nuestro disco extraible USB, mejor conocido como pendrive.

La guía está en construcción y corrección y está dirigida a personas que tienen poco o ningún conocimiento en el uso en el tema.

EL PENDRIVE: Es una unidad de almacenamiento masivo identificada como unidad extraíble, dependiendo del computador, en otras palabras es un Hardware que almacena información de cualquier tipo. La información perdura dentro del dispositivo aunque el dispositivo sea removido de la computadora.

COMO USAR SU PENDRIVE.

Leer una información (Documento, Carta, Fotos, etc.) contenida en un Pendrive – Forma 1:

  1. Introducir el Pendrive en el puerto USB.
  2. Esperar reproducción automática del Pendrive (En algunos casos esto nunca ocurre).
  3. Buscar la opción “abrir carpeta para ver archivos ” y darle clic (seleccionar).
  4. Seleccionar el archivo deseado.

Leer una información (Documento, Carta, Fotos, etc.) contenida en un Pendrive – Forma 2:

  1. Introducir el Pendrive en el puerto USB.
  2. Acceder a MI PC.
  3. Buscar el dispositivo y darle doble clic (abrir).
  4. Seleccionar el archivo deseado.

Almacenar una información. (Aplica a cualquier tipo de archivo que esté guardado en la máquina; documentos, presentaciones, etc.):

  1. Una vez guardado el documento en alguna carpeta del computador (Mis Documentos, Escritorio, etc.) se localiza el archivo, se selecciona con clic derecho para poder visualizar el menú de opciones.
  2. Se localiza copiar seleccionándolo con clic izquierdo.
  3. Se va a El Equipo ó Mi PC.
  4. Se abre el Pendrive, con doble clic izquierdo.
  5. Una vez a dentro se selecciona en cualquier parte de la carpeta con el clic derecho, “pegar” y al pegar ya está almacenado.

Opción de guardado rápido de una información en el Pendrive (alternativa a los pasos anteriores).

  1. Buscar un archivo y hacer clic con el botón derecho.
  2. En menú de opciones ir a enviar a.
  3. En menú enviar, ir a disco extraible
Retirar un Pendrive de forma segura – Forma 1:
  1. Ir a Mi PC ó a la ubicación El equipo localizar el Pendrive.
  2. Hacer clic derecho para visualizar Menú de opciones.
  3. Hacer clic izquierdo en expulsar.
  4. Retirar el Hardware (Pendrive).
Retirar un Pendrive de forma segura – Forma 2:
  1. Buscar en la barra de tareas, el icono quitar Hardware con seguridad.
  2. Seleccionar con un solo clic en el icono, para ver opciones.
  3. Darle con clic izquierdo en la opción: Extraer la unidad de almacenamiento masivo de forma segura.
  4. Retirar el Hardware (Pendrive).
Retirar un Pendrive de forma segura – Forma 3:
  1. Apagar el computador completo.
  2. Retirar el Hardware (Pendrive).
Como formatear el Pendrive.
FORMATEAR: Es una utilidad informática en sistemas de archivos que permite borrar toda la información contenida en un dispositivo de almacenamiento de datos, también permite, en ocasiones, corregir errores e incluso repararlo.
  1. Introducir el Pendrive al PC.
  2. Hacer clic en inicio, ir a equipo o a mi PC.
  3. Aparece icono de Pendrive (personalizado).
  4. Sobre el icono hacer clic derecho y luego hacer clic izquierdo en formatear.
Como cuidar el Pendrive o memoria USB.
  1. Evitar caídas o golpes.
  2. Mantener lejos de campos magnéticos.
  3. No exponer a calor extremo.
  4. Conserve en sitios secos y frescos lejos de la humedad.
Fuentes de información:
Nota 1: la guía original tenía otros enlaces que actualmente no están disponibles.
Nota 2: esta guía está en construcción y revisión, para observaciones realice un comentario en esta página  🙂

¿Qué es RSS?

RSS es una forma muy sencilla para que puedas recibir, directamente en tu computadora o en una página web online (a través de un lector RSS) información actualizada sobre tus páginas web favoritas, sin necesidad de que tengas que visitarlas una a una. Esta información se actualiza automáticamente, sin que tengas que hacer nada. Para recibir las noticias RSS la página deberá tener disponible el servicio RSS y deberás tener un lector RSS [1].

Si existen varias páginas web que te interesan que van actualizando sus contenidos y te gustaría mantenerte informado, un lector RSS te ahorrará mucho tiempo en esta tarea. Gracias al RSS, no tendrás que visitar cada una de las páginas web que te interesan para ver si han añadido o no algún artículo que te pueda interesar. Estas páginas te informarán a ti (a través de tu lector de RSS). Cuando ingreses a tu Lector RSS (o RSS Reader), estarás automáticamente informado sobre todas las novedades que se han producido en todas las páginas web que has dado de alta [1].

Si quieren ampliar los conceptos básicos acerca de RSS les recomiendo la página http://www.rss.nom.es/ allí encontrarán información básica explicada de manera sencilla.

Fuente:

Instalar Servidor Debian/Raspbian/Ubuntu

A continuación resumo en pocos comandos los pasos de instalación de un servidor Debian/Ubuntu/Raspbian. Compilando artículos publicados en este blog bajo la etiqueta #Server6001. Agregando cosas inéditas, para tener en un sólo post todos los pasos que suelo aplicar en un primer momento para la instalación de un servidor Linux basado en Debian.

sudo su

apt-get update && apt-get upgrade

apt-get install openssh-server apache2 apache2-mod-php7.0 php7.0 php7.0-mysql mysql-client mysql-server php-curl tomcat8 vsftpd phpmyadmin php-intl php-soap php-xmlrpc

sudo ln -s /usr/share/phpmyadmin /var/www/

Instalar Cliente no NO-IP

Configurar Servidor FTP

Instalar MariaDB

Explicación de lo que estamos instalando:

openssh-server: Servidor SSH.

apache2: Servidor HTTP.

php7.0: Servidor PHP.

mysql-client: Necesario para administrar MySQL desde la cónsola.

mysql-server: Servidor MySQL.

tomcat8: Servidor Java.

vsftpd: Servidor FTP.

php-curl: Esta extensión es uno de los requisitos obligatorios para instalar sistemas algunos sistemas como Moodle.

Más info en:

🙂

Kanban for WordPress: un plugin de agilidad.

kanbanwp-logoKanban for WordPress (Kanbanwp)

es un plugin que te permite crear un tablero Kanban dentro de tu instalación de WordPress, tan sencillo de instalar y utilizar que casi da asco.

board-full-basic

Trae de manera predeterminada las columnas básicas de un tablero kanban, pero se pueden personalizar todas, agregar nuevas, quitarlas o cambiarles el texto si lo prefieres.

También puedes crear proyectos con los usuarios de la instalación de WordPress o crear usuarios sólo para este plugin, actuando como un sistema aparte.

En la web del plugin (kanbanwp.com) es posible encontrar agregados de pago para completar sus funcionalidades, sin embargo, el plugin básico se mantiene gratuito.

Falta de capacidad como indicador de éxito de un sitio web

Una pequeña startup* que llamaremos RedBuho quiere publicar en Internet un sitio web con su idea empresarial, se trata de una red social general para compartir y guardar cualquier tipo de material multimedia.

El dueño de RedBuho (dueño, programador, analista, diseñador y el que hace todo porque es el único), ideó su portal en PHP* y MySQL* ya que, le resulta muy sencillo encontrar servidores gratuitos o muy económicos para subir su desarrollo.

El dueño de RedBuho, que llamaremos Mr. Bigowl, quiso probar un poco su conocimiento de Lean*, así que publicó su red social con las mínimas características necesarias para que fuera operativa.

Luego de dos meses, un famoso y respetado profesor de informática y seguridad en la web, con muchos seguidores en Youtube por lo didáctico y actualizado de sus videos, hizo una reseña de esta nueva red social, mencionó que a pesar de tener muy pocos usuarios, menos de 100, ofrece unas características innovadoras y muy interesantes. Inmediatamente, en una hora, RedBuho pasó de 85 usuarios a 1200, a la siguiente hora a 3500 y a la siguiente hora el portal dejó de funcionar por el exceso de visitas y registros.

En los siguientes días RedBuho tuvo serios problemas de disponibilidad, se caía constantemente, tenía lentitud, etc…

Hasta este punto de la historia probablemente alguien pensaría que Mr. Bigowl se equivocó al decidir montar su red social en un server gratuito, que no tuvo previsto soportar cierta cantidad de usuarios, que planificó mal, en fin, que todos estos eventos pueden verse como un fracaso.

Nada más alejado de la realidad…

Mr. Bigowl tuvo el problema más deseado por una empresa emergente, la falta de capacidad para un exceso de demanda. No ha fracasado, al contrario, tuvo demasiado éxito.

Ahora vienen nuevas decisiones…

  • Limitar la cantidad de usuarios mientras comienza a ser rentable el sitio.
  • Arrendamiento de hosting con más capacidades.
  • Buscar apoyo con publicidad u otro tipo de patrocinio

Lo realmente agradable es que alguna decisión tendrá que tomar. Si el sitio no hubiera tenido éxito, el pequeño cascaron de un hosting gratuito le hubiera sido suficiente para tener su proyecto.

Las conclusiones a las que quiero llegar son las siguientes:

  1. No llenes tu lista de cosas por hacer antes de lanzar tu producto. Sal al mercando con lo mínimo que necesites (eso se llama Producto Mínimo Viable).
  2. Si lanzaste tu producto y tienes problemas de capacidad, celébralo, porque ahora tendrás la tarea de pensar una estrategia para sopesar esa carencia, eso es un reto que deriva del éxito.
  3. No le temas al fracaso. El fracaso es información para mejorar.
  4. No le temas al éxito.

Glosario:

Startup: Una compañía startup, compañía de arranque, compañía incipiente o, simplemente, compañía emergente es un término utilizado actualmente en el mundo empresarial el cual busca arrancar, emprender o montar un nuevo negocio y hace referencia a ideas de negocios que están empezando o están en construcción, es decir son empresas emergentes apoyadas en la tecnología. [wikipedia]

PHP: Lenguaje de programación, muy usado.

MySQL: Base de Datos.

Lean Startup: Filosofía para abordar el lanzamiento de negocios y productos que se basa en aprendizaje validado, experimentación científica e Iteración en los lanzamientos del producto para acortar los ciclos de desarrollo, medir el progreso y ganar valiosa retroalimentación de los clientes. De esta manera las compañías, especialmente startups pueden diseñar sus productos o servicios para cubrir la demanda de su base de clientes, sin necesitar grandes cantidades de financiación inicial o grandes gastos para lanzar un producto.

Hosting: Servidor o servidores que sirven que ofrecen los recursos necesarios para alojar un sitio web y hacerlos de acceso público en Internet.