Top videos de la semana #1

Esta semana hay varios videos interesantes que me gustaría compartirles

1.- #Emprendimiento: Reseña biográfica de Elon Musk uno de los empresarios más importantes y revolucionarios de la actualidad. Publicado por: Platzi

2.- #Emprendimiento: Aunque la idea del siguiente video es explicar los tipos de inversores que existen, lo que más me llamó la atención es la explicación de cómo se estima la valoración de una empresa a través de sus acciones. Publicado por: EmprendeAprendiendo.

3.- #Motivación: El siguiente, aunque es un video del año pasado publicado por TEDx Talks, este es una recomendación reciente del canal SimplyOz, donde Maikel Melamed cuenta un poco de su historia.

4.- #Juego: Un tutorial de Minecraft para hacer una granja muy sencilla (bastante mejorable), pero fácil para hacer con pocos recursos.

5.- #Emprendimiento: En este video Laura Ribas responde a través de su experiencia a la eterna dicotomía de los emprendedores ¿Emprender empleado o dedicar el 100% al emprendimiento?

 

“Uncompilable source code” RuntimeException en NetBeans

netbeans-ide-logoProblema: Programando en Netbeans 6.9.1 al ejecutar el proyecto, un mensaje de error que dice “Uncompilable source code”.

Causa: Corrupción de los archivos temporales del IDE.

Solución: , Borrar los archivos que están en la ruta:

$USER/.netbeans/<version>/var/cache/

GOK: GNOME Onscreen Keyboard

Un teclado en pantalla es básicamente una herramienta de software creada con la finalidad de recrear la distribución y configuración de un teclado de manera virtual, de tal modo que pueda ser usado a través de pulsaciones con el ratón(clicks).

GOK, siglas de  GNOME Onscreen Keyboard (Teclado en pantalla de GNOME), es una aplicación creada para el escritorio GNOME del sistema operativo GNU/Linux, que permite interactuar con la computadora a través del ratón o dispositivos alternativos.

Para instalarlo en Ubuntu se abre un terminal y se coloca el siguiente comando

sudo apt-get install gok

GOK no se limita a recrear las teclas de un teclado común como haría un sistema similar, además provee de opciones para interactuar de manera dinámica y adaptativa con las opciones de la aplicación que estemos ejecutando en ese momento.

Pantallazo-gok

En la imagen vemos la pantalla principal de GOK.

La opción Componer, es la que muestra la concepción básica de un teclado virtual.

Pantallazo-teclado-gok

La opción Ventana, sirve para configurar el tamaño de la ventana de GOK.

Pantallazo-ventana-gok

La opción Ratón emula los controles de un ratón convencional.

Lanzador provee las opciones de abrir aplicaciones (navegador web, editor de texto y el terminal básicamente).

Activar muestra las teclas que permiten al usuario navegar por su escritorio y utilizar las aplicaciones que tiene abiertas en ese momento, GOK muestra información sobre las preferencias de esta aplicación y también el menú de ayuda.

Menús, Barra de herramientas y Extractor IU muestran las teclas que reflejan elementos del menú, de la barra de herramientas, y de otros elementos de la interfaz de usuario.

Según la documentación [3], la ventaja principal de GOK es que este panel virtual y todas sus funciones, se pueden acceder utilizando el clic directo con un ratón convencional o cualquier otro método alternativo de selección. En concreto esta aplicación permite utilizar 6 formas posibles alternativas al clic directo para seleccionar cualquier tecla del menú, entre ellas, las más importantes son acceso por barrido (accionando el conmutador se inicia el barrido secuencial por filas; cuando la aplicación llega a la tecla que queremos, se acciona de nuevo el conmutador para seleccionarla); y el acceso por método Dwell, donde la selección se realiza cuando el puntero del ratón permanece un determinado periodo de tiempo sobre una tecla.

Fuentes:
[1] – http://wiki.mundoaccesible.org.ve/index.php?title=GOK
[
2] – Sistema de ayuda de GOK.
[3] – http://canalaccesible.guadalinfo.es/sitio/index.cgi?wAccion=news&wid_news=158&wid_seccion=&wid_item=&wid_grupo_news=3

Quiero (por Alba Crespo)

Elixir de fuego
quiero darte;
en tibio vaso para dioses,
tersura de pétalos
sobre tu seda humana,
tenerte así… así;
en las arterias de mi ser.

Alba Crespo - 4/05/94 - Tomado del libro Facetas. Pág. 23.

Foco vs. Multitarea

El gran vicio y defecto de la persona con mucha energía es la multitarea (gente multitasking), asumen, asumen, asumen y asumen tareas, todas las considera necesarias, todas igual de importantes y así, va diariamente pensando en 20 cosas a la vez, y tratando de hacer todas, pero, como dicen en mi país, el que asa dos conejos a la vez, alguno se le quema. Esto ocurre también en las empresas con personas que tienen amplias aptitudes, le asignan 4, 5 proyectos a la vez y participa en otros tantos. Al final termina siendo poco productivo en todos.

¿Cómo sugieren los expertos abordar el tema? Una cosa a la vez en todas las etapas del trabajo. Es decir, si tienes una tarea que hacer, dedícate a ella hasta terminarla, si tienes 3 proyectos, deberías estar en uno, y hasta no terminarlo, no asumir otro. Hacer varias cosas a la vez baja tu rendimiento en todo, por muy eficiente que seas para hacer las cosas.

Recomendación: Hacer una lista de tareas por tu proyecto, priorizarla (ordenarlas por prioridad), e ir una a una sin intentar hacer dos o más a la vez. Verás como sales del conjunto más rápidamente.

La fallida migración de Byethost a 000webhost ¿DNS?

Hace relativamente poco, tenía mi WordPress muy embasurado y obsoleto, pero un intento de actualización del blog conllevó a un error que no pude recobrar, probablemente un error en la comunicación que hizo que quedaran archivos corruptos.

Aproveché el problema para migrar el blog completo de Byethost a un renovado 000webhost que hasta ahora no me había dejado mal, tras largas horas y los cambios de los DNS logré cambiar el servidor y hacer que el blog se pareciera mucho a lo que tenía antes… Pero en 000webhost pasa horas abajo diariamente, eso ha generado que las visitas también vayan a menos.

Ahora, no estoy seguro si realmente es 000webhost, que está teniendo un rendimiento deplorable o es que los DNS no se han terminado de actualizar, o es mi blog que sigue embasurado (asunto menos probable, ya que, los períodos de inactividad son aparentemente aleatorios), lo importante es que en los próximos días, tendré que migrar de nuevo el blog, tengo la esperanza de hacerlo a un server propio, pero si no, tendré que volver a Byethost, lo importante es que mientras tanto, seguirán notando que el blog no carga en ciertos momentos, me disculpo por eso.

Recuerda que si te suscribes por correo, las cosas que voy publicando llegan directamente a tu correo (sin necesidad si quiera de ingresar directamente en la página).

Configurar una VLAN y enlaces troncales en un Switch Cisco

A continuación veremos como crear dos redes LAN virtuales (VLAN) usando un Switch Cisco. Lo que queremos lograr

Ejercicio propuesto

A las Laptops la confuguraremos con los siguientes parámetros:

  • Laptop0: ip = 192.168.1.2/24 default gateway = 192.168.1.1
  • Laptop1: ip = 192.168.1.3/24 default gateway = 192.168.1.1
  • Laptop2: ip = 172.16.1.2/24 default gateway = 172.16.1.1
  • Laptop3: ip = 172.16.1.3/24 default gateway = 172.16.1.1

A continuación los comandos mínimos de configuración necesarios del Router, nótese que la misma interfaz (fastEthernet 0/0), debe tener 2 IPs, ya que, el Router será el Default Gateway de las dos redes virtuales. Esto se logra con un enlace trocal, el protocolo más común para esto se llama 802.1Q. Los comandos para lograr esto son:

enable
configure terminal
interface fastEthernet 0/0
no shutdown
exit

 

interface fastEthernet 0/0.10
encapsulation dot1Q 10
ip address 192.168.1.1 255.255.255.0
exit


interface fastEthernet 0/0.20

encapsulation dot1Q 20
ip address 172.16.1.1 255.255.255.0

Note que 0/0.20 es una manera de decir que estamos creando una subinterfaz 20 dentro de la interfaz 0/0 del router y que usaremos encapsulación dot1Q.

Ahora los comandos del Switch, primero configuramos la VLAN 10, que se llamará GERENCIA.

enable
vlan database
vlan 10 name GERENCIA
exit


configure terminal

interface fastEthernet 0/1
switchport mode access
switchport access vlan 10
exit

 

interface fastEthernet 0/2
switchport mode access
switchport access vlan 10
exit

No se recomienda el uso de el comando vlan database, ya que, los cambios se guardan al salir del modo de configuración, si tenemos muchas interfaces configuradas, todas serán guardadas al final, note también que se configuró cada una de las interfaces por separado, se pueden configurar varias interfaces a la vez con rangos.

A continuación veremos los comandos para configurar la VLAN 20 haciando uso de las mejores prácticas:

enable
configure terminal
vlan 20
name RRHH
exit


interface range fastEthernet 0/3 – 4

switchport mode access
switchport access vlan 20

Note que no se usa el comando vlan database, además el uso de la opción range… Ahora sólo falta establecer la conexión troncal para que el Switch permita el trafico de las dos redes virtuales hacia el Router.

enable
configure terminal
interface fastEthernet 0/24
switchport mode trunk

A continuación otros comandos que nos pueden ser de utilidad mientras estamos creando VLAN.

Ver las VLAN creadas:
show vlan

configurar varias interfaces no consecutivas:
interface range fastEthernet 0/5 , fastEthernet 0/9

ver tablas de MacAddress en Switch con plataforma nueva:
show mac address-table

ver tablas de MacAddress en Switch con plataforma antigua:
show mac-address-table

Ver información de enlaces troncales:
ip interfaces trunk

Error 500 instalando un tema en WordPress

error500Aunque no es frecuente que esto ocurra, es posible que al instalar un tema (theme), en WordPress se produzca un error 500 que nos hará imposible el acceso ni al contenido, ni a la administración…

La manera más rápida de solucionar este inconveniente es renombrar la carpeta del tema vía FTP, esto forzará a que se visualice el tema por defecto (predeterminado), de la instalación.

Nota: si borraste el theme principal, la página pública se mostrará en blanco, pero podrás acceder a la administración.

¿Cómo conservar un buen hombre?

Hace poco una amiga en una historia de su Whatsapp publicó la imagen a continuación… Y me llamó mucho la atención porque es muy extraña, sin embargo, me pareció propicio escribir al respecto, ya que, muchas mujeres la pueden interpretar muy mal.Imaginemos que por flojera, la persona que lo lee, se lleva la idea de la primera frase: “Recuerda esto: no hay nada que puedas hacer para “conservar” a un buen hombre”… Allí le respondería lo siguiente a la mujer que considere eso:

Es una total mentira que “no hay nada que puedas hacer para ‘conservar’ a un buen hombre”. Lo único que tendría que hacer una mujer es valorarlo y hacerlo sentir valorado. Entregarle su corazón, sus sentimientos, su sinceridad… Lamentablemente (no digo que sea tu caso), muchas mujeres sienten que son las únicas que tienen que ser consentidas (quizás por machismo, quizás por cultura) y no se dan cuenta que el hombre también necesita atención y detalles. El hombre no sólo está para amar, sino para ser amado, así como la mujer no sólo está para ser amada, está para expresar su amor y hacer sentir amado al hombre… Así se conserva a un buen hombre… Haciéndolo sentir importante.

Para aclarar las cosas: El escrito en la imagen fue hecho por un hombre, no por una mujer y además está incompleto… El texto completo dice:

“Recuerda esto: no hay nada que puedas hacer para “conservar” a un buen hombre, y el hombre equivocado no vale la pena ser conservado. Entonces, es posible que te preguntes: “¿Qué tiene que hacer una mujer para conservar a un hombre?”. La respuesta es… que debes olvidarte de la idea de que tienes el poder para conservarlo, y debes enfocarte en encontrar a un buen hombre que te ame y te respete lo suficiente como para querer quedarse: ese es el secreto.

Como verás, es posible que estés haciéndolo todo bien, pero si ese hombre no te ama ni te respeta, y si no aprecia lo que haces por él, tu esfuerzo será en vano.” – Mr. Amari Soul #ReflexionesDeUnHombre

Mujer: recuerda algo, tu creas tu suerte en el amor. No le pidas rosas a alguien que sabes que no te las va a dar. Tampoco destruyas al que si te da rosas, porque quizás les quites las ganas de creer en el amor. Abre los ojos, se inteligente.

Comtemplo la Estrella (por Alba Crespo)

Mirando la estrella,
te contemplo en ella,
oliendo las flores me lleno de vida
oyendo los trinos sigo tus huellas;
sintiendo mis pasos
te veo caminando…
juntos a la hojarasca
hasta llegar al cielo,
promesa de fe y esperanza.

Alba Crespo - 24/04/88 - Tomado del libro Facetas. Pág. 32.